We use proprietary and third party´s cookies to improve your experience and our services, identifying your Internet Browsing preferences on our website; develop analytic activities and display advertising based on your preferences. If you keep browsing, you accept its use. You can get more information on our Cookie Policy
Cookies Policy
Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

Hello fermin thanks for the answer

well, i think different points are not clear for me .....

My SW context :

     - I run a docker orion (version 0.27.0-next) in debug mode 

     - i run a compiled  fiware-cygnus-0.11.0  locally( works well  when i send a notif to http://localhost:5050/notify, my  CKAN sink receive the notif) .. good

The first issue is about V1 or V2 , not clear for me ...

i have registrated a subscription with v2 prefix

curl localhost:1026/v2/subscriptions -s -S --header 'Content-Type: application/json' --header 'Accept: application/json' -X POST-d @- | python -mjson.tool) <<eof {="" "expires":="" "2016-02-18t01:00:00.00z",="" "notification":="" {="" "attributes":="" [="" "temperature",="" "humidity"="" ],="" "callback":="" "http:="" localhost:5050="" notify",="" "throttling":="" 1="" },="" "subject":="" {="" "condition":="" {="" "attributes":="" [="" "temperature="" "="" ],="" "expression":="" {="" "q":="" "temperature="">40" } }, "entities": [ { "id": "Bcn-Welt5", "type": "Room" } ] } } EOF

i see it in the subscription list ...... with curl localhost:1026/v2/subscriptions .......

so want to create/update entities . So i use v1 or v2 for entities ?

best regards phil