We use proprietary and third party´s cookies to improve your experience and our services, identifying your Internet Browsing preferences on our website; develop analytic activities and display advertising based on your preferences. If you keep browsing, you accept its use. You can get more information on our Cookie Policy
Cookies Policy
Ask Your Question
0

fiware-service in Orion 2.2.0

asked 2019-06-18 16:04:56 +0100

pasquy73 gravatar image

updated 2019-06-18 16:05:31 +0100

Hi all, I'm using Orion Context Broker 2.2.0 and I'm using fiware-service and fiware-servicepath to separate the data, but I've the same results with or without the fiware-service. Is it my fault or not?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2019-06-26 08:15:11 +0100

jmcantera gravatar image

I would not recommend you to use the Fiware-Service-Path, as you may easily end up generating Entities with same Id in different Service-Paths without having a clue from which Service-Path are Entities coming when you query.

Wrt Service, please check, using the MongoDB client, that you have one mongoDB DB per fiware-service and that your entities are correctly stored.

Thanks!

edit flag offensive delete link more

Comments

Yes, you are right, but I tried with a Orion VM in FIWARE Lab (1.3.0 and 2.0.0next) and both Orion stored data in to orion-vehicles collections. I installed manually Orion 2.2.0 on Centos 7 and I have only collection: orion, with fiware-service: vehicles. Probably it's my fault in the installation.

pasquy73 gravatar imagepasquy73 ( 2019-06-27 10:25:26 +0100 )edit

you need to execute a command `show databases` and see how many orion-xxx are

jmcantera gravatar imagejmcantera ( 2019-06-27 10:27:40 +0100 )edit

Yes, I'm using show databases command and also a mongo client to connect on mongo instance (after open port). In my 2.2.0 instance I can see only after '> show databases': admin 0.000GB config 0.000GB local 0.000GB orion 0.000GB

pasquy73 gravatar imagepasquy73 ( 2019-06-27 10:51:43 +0100 )edit

The only difference is the version of mongo. I'm using 4.0.9 for Orion 2.2.0, instead Orion 2.0.0next uses 3.6.9

pasquy73 gravatar imagepasquy73 ( 2019-06-27 11:51:15 +0100 )edit

probably, try

jmcantera gravatar imagejmcantera ( 2019-06-27 12:00:02 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-18 16:04:56 +0100

Seen: 541 times

Last updated: Jun 26