We use proprietary and third party´s cookies to improve your experience and our services, identifying your Internet Browsing preferences on our website; develop analytic activities and display advertising based on your preferences. If you keep browsing, you accept its use. You can get more information on our Cookie Policy
Cookies Policy
Ask Your Question

Ckan and Orion with only one public IP

asked 2016-03-11 09:15:47 +0200

migmobl gravatar image


I want to integrate ckan with orion and now I have only one public IP.

How is the correct way to install this architecture?


Miguel M.

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted

answered 2016-03-21 12:04:47 +0200

Fermín Galán gravatar image

I understand that as long each one (i.e. Orion and CKAN) runs in a different port, there is no problem in such deployment.

In particular, in the case of Orion, you can adjust the port editing the BROKER_PORT parameter in the /etc/sysconfig/contextBroker file (default value is 1026). You need to restart Orion service with /etc/init.d/contextBroker restart if you modify the configuration file.

edit flag offensive delete link more


I understand that the only way I have to proceed would be by modifying the configuration and using different ports, but it is not possible to use different domains. I think that it would easier if I could assign different IP’s or DNS’s to not have to set redirections between machines.

migmobl gravatar imagemigmobl ( 2016-03-21 12:52:20 +0200 )edit

answered 2016-04-27 15:42:28 +0200

jicg gravatar image

You can do this without problems. --- Even it could be possible to have 2 virtual hosts one for each enabler in serveral ways, for example, if you wanted to do port forwardng you could read this article:


There are some easier ways to do this, for example ssh port forwarding (imagine your frontend is ckan and your backend is orion, so you want to forward port 1026):

ssh -f -N -o ServerAliveInterval=30 -L 0:1026:${ORION_IP}:1026 ${LOCALHOST_USER}@localhost

You should be able to ssh your localhost with your $LOCALHOSTUSER (i.e. set a ney public key to ssh to your localhost with ssh-keygen and add your new public key to your .ssh/authorized_keys)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower


Asked: 2016-03-10 14:27:46 +0200

Seen: 19,268 times

Last updated: Apr 27 '16