We use proprietary and third party´s cookies to improve your experience and our services, identifying your Internet Browsing preferences on our website; develop analytic activities and display advertising based on your preferences. If you keep browsing, you accept its use. You can get more information on our Cookie Policy
Cookies Policy
Ask Your Question
0

Arduino and IDAS

asked 2016-08-05 09:19:39 +0200

pasquy73 gravatar image

Hi all, I would like to connect my Arduino with IDAS, to store an attribute in the Orion Context Broker. Could you help me? Could you suggest me a guide or tutorial?

Thank you

edit retag flag offensive close merge delete

3 answers

Sort by » oldest newest most voted
0

answered 2016-08-10 14:13:22 +0200

jmcantera gravatar image

here you can find a tutorial

https://www.fiware.org/2015/06/10/iot...

edit flag offensive delete link more
0

answered 2016-08-12 12:30:50 +0200

pasquy73 gravatar image

Thank you for reply. I would like to use the "OMA Lightweight M2M IoT Agent" with arduino configuration, as you can see at this link https://github.com/telefonicaid/light... but I don't know how to configure both Arduino and the IoT agent.

Regards, Pasquale

edit flag offensive delete link more
0

answered 2016-08-22 09:21:05 +0200

The most difficult part in order to connect your Arduino board to the IOTA will be to find a good Arduino library for working with LightweightM2M. Once you have it, you must provision the device in the agent (you can find an example in this tutorial ). Once you have both, you can look at the examples in that same tutorial or the LWM2M specification for the operations you can do on your device. I suggest you follow the tutorial with just the Agent first (and the provided client), and then, try the connection, once you have it working as you would expect.

edit flag offensive delete link more

Comments

Thanks a lot Daniel, I followed the tutorial. It's ok. I'm using all together on the same VM (on orion VM). But now I want to install the client on my PC, but I cannot connect on IoT server (in FIWARE Lab). I'm using the public IP: "connect 185.38.252.131 5684 robot1 /". Can you help me? Thanks

pasquy73 gravatar imagepasquy73 ( 2016-09-01 11:55:34 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2016-08-05 09:19:39 +0200

Seen: 1,257 times

Last updated: Aug 12 '16